use strict;
my $str = '<p class="wp-caption-text"><span>android m marshmallow</span></p>
<html>
<body>
<img src="a6marshmallow.jpg"/>
<p class="wp-caption-text"><span>android m marshmallow</span></p>
<div class="wp-caption-text"><p>a more complex example :oooooo</p></div>
</body>
</html>';
my $regex = qr/<(\w+).*?class="wp-caption-text".*?>[\s\S]*?<\/\1>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}