import Foundation
let pattern = #"<(\w+).*?class="wp-caption-text".*?>[\s\S]*?<\/\1>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<p class="wp-caption-text"><span>android m marshmallow</span></p>
<html>
<body>
<img src="a6marshmallow.jpg"/>
<p class="wp-caption-text"><span>android m marshmallow</span></p>
<div class="wp-caption-text"><p>a more complex example :oooooo</p></div>
</body>
</html>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)