package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:[A-Z]{2}-\d{2}-\d{2})|(?:\d{2}-[A-Z]{2}-\d{2})|(?:\d{2}-\d{2}-[A-Z]{2}))`)
var str = `00-00-AA
AA-00-00
00-AA-00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}