#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\d+[.,]?(\d+\s*k?|x{2,3})(?=\s*(original|actual|highway)?\s*miles)|(?<=mile(s|agex?):?\s*(is|~)?\s*)\d+[.,]?(\d+(\s*k)?|x{2,3})|(\d+(\s*K)|x{2,3})"
Local $sString = "123456789012"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")