use strict;
my $str = '123456789012';
my $regex = qr/\d+[.,]?(\d+\s*k?|x{2,3})(?=\s*(original|actual|highway)?\s*miles)|(?<=mile(s|agex?):?\s*(is|~)?\s*)\d+[.,]?(\d+(\s*k)?|x{2,3})|(\d+(\s*K)|x{2,3})/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}