using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<p>)[\x{0590}-\x{05ff}\x{0600}-\x{06ff}]";
string substitution = @"<p class=""foo"">";
string input = @"<p>para 1</p><p>نص عربي أو فارسي</p><p>para3</p>";
RegexOptions options = RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}