import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?:\\/\\/(www.|de.)?linkedin.com\\/(mwlite\\/|m\\/)?in\\/([a-zA-Z0-9À-ž_.-]+)\\/?)";
final String string = "https://de.linkedin.com/in/andré-test-9dfdr47a16a\n"
+ "https://www.linkedin.com/in/lenatest/\n"
+ "https://de.linkedin.com/in/test-jäcke-dff0746\n"
+ "https://de.linkedin.com/in/irenetest\n"
+ "https://www.linkedin.com/in/markus-test-7dfdfc38/?originalSubdomain=de\n"
+ "https://www.linkedin.com/in/test-görs-2fdf562a/\n"
+ "https://www.linkedin.com/in/test-müller-82dfdfd0143/\n"
+ "https://www.linkedin.com/in/marie-test-grübler-dfdfdsf0/\n"
+ "https://www.linkedin.com/in/özgür-test-dfdfdf080/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}