#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9_]|_$|__|[^0-9a-z_]"
Local $sString = "hello" & @CRLF & _
"he_llo" & @CRLF & _
"hel_1o" & @CRLF & _
"he_l_lo" & @CRLF & _
"hel__lo" & @CRLF & _
"_hello" & @CRLF & _
"8hello" & @CRLF & _
"hello_" & @CRLF & _
"abc" & @CRLF & _
"_abc" & @CRLF & _
"1abc" & @CRLF & _
"abc_" & @CRLF & _
"abc1" & @CRLF & _
"ab$c"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")