re = /\+\d{2}\s{1,9}\d{2}(?:\s{1,9})?\d{8}|\d{4}(?:\s{1,9}\d{6}(?:\d{4})?|\d(?:\s{1,9})?\d{6})/m
str = '+99 99 99999999
9999 999999
99999 999999
99999999999
+99 9999999999
9999 9999999999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end