re = /(\((?:[^()]|(?1))*\))$/m
str = '(((()()())))
"some text (and words) more text (and words)
textrighthere(with some more)
little trickier (this time) with (all of (the)(values))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end