# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\[]*(\[.*?\])[^\[]*/\1/g;t' <<< "[D-1.1.1-A] - bla bla text here[D-1.1.1-B] - some more bla bla text here[D-1.1.1-C] - even more bla bla
"