Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
('|")([^\{\}]*)(\#\{([^\}]*)\})([^'"]*)('|")
/
gm
Input 1
1
New
'asdasd #{some} asda asd #{asdasd} ${stuff} asdas as_ $asd#as' "asdasd #{some} asda asd ${stuff} asdas as_ $asd#as" '#{some}' "#{some}" "background-image: url(#{cover})"
Substitution
$1$2$1+$4+$1$5$6
'asdasd #{some} asda asd #{asdasd} ${stuff} asdas as_ $asd#as' "asdasd #{some} asda asd ${stuff} asdas as_ $asd#as" '#{some}' "#{some}" "background-image: url(#{cover})"