re = /(^[^=\n]+$)(?!(?s).*^\1\s*=)/m
str = 'a
b
c
d
e
f
g
h
i
j
k
l
a=dc
ca=ref
d=23'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end