# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(is [a-zA-Z]+)/$1 <-- loop over each capture instance to build your array./g;t' <<< "Sample text:
((is hot y is dry) y is windy)
Output: [is hot , is dry , is windy]
Language: javascript"