#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(is [a-zA-Z]+)"
Local $sString = "Sample text: " & @CRLF & _
"((is hot y is dry) y is windy)" & @CRLF & _
"Output: [is hot , is dry , is windy]" & @CRLF & _
" " & @CRLF & _
"Language: javascript"
Local $sSubst = "$1 <-- loop over each capture instance to build your array."
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)