package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^(bog)]`)
var str = `hog
dog
bog`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}