// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b\d{12,22}\b").unwrap();
let string = "ESN: 355496930746061, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 35722223989377, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 354553495098527, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 350448885354834, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 352917263813650, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 351646277216193, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 357883403755026, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 352917262541195, Shipper:";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}