import Foundation
let pattern = #"\b\d{12,22}\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"ESN: 355496930746061, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 35722223989377, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 354553495098527, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 350448885354834, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 352917263813650, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 351646277216193, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 357883403755026, Shipper: FEDEX, TrackingNumber: 743700616165|ESN: 352917262541195, Shipper:"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)