using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[1-9][0-9]*[Xx]\b";
string input = @"Should return true:
2x
31x
3x abcd
1x
100x
Should return false:
2x3
3xabc
asdf3x
0x";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}