import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[1-9][0-9]*[Xx]\\b";
final String string = "Should return true:\n\n"
+ "2x\n"
+ "31x\n"
+ "3x abcd\n"
+ "1x\n"
+ "100x\n\n"
+ "Should return false:\n\n"
+ "2x3\n\n"
+ "3xabc\n\n"
+ "asdf3x\n\n"
+ "0x";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}