Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
%({)?(?P<macro_name>[a-z_][a-z0-9_]*)(?(1)})
/
gm
Input 1
1
New