package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(ah|kh|qh|3c|2c)\b`)
var str = `ah
yeah
kha
kh`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}