package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)define service\s\{.*(Service 2|Command B).*\}`)
var str = `define service {
service_description Service 1
use Template 1
host_name Host 1
check_command Command A
}
define service {
service_description Service 2
use Template 1
host_name Host 1
check_command Command B
}
define service {
service_description Service 3
use Template 1
host_name Host 1
check_command Command C
}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}