package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\s,]+(?:,\s*[^\s,]+)*$`)
var str = `foo-bar, hey_friend, 56-8, 7_88, elephant$n`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}