$re = '/(0{3,}|\W+)/m';
$str = '5067/33177
506700000033442
5067…34142
5067-33304';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);