using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\x{627}\x{625}\x{623}\x{622}]\x{062D}\x{0645}\x{062F}";
string input = @"Ø£ØÙ…د
اØÙ…د
Ø¥ØÙ …د
Ø¢ØÙ…د";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}