const regex = /[\x{627}\x{625}\x{623}\x{622}]\x{062D}\x{0645}\x{062F}/ug;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\x{627}\\x{625}\\x{623}\\x{622}]\\x{062D}\\x{0645}\\x{062F}', 'ug')
const str = `Ø£ØÙ…د
اØÙ…د
Ø¥ØÙ…د
Ø¢ØÙ…د`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}