$re = '/(\w{2})\w*\1/';
$str = 'The dodo was one of the sturdiest birds. An educated termite may learn how to operate a phonograph, but it\'s unlikely. I sense that an amalgam that includes magma will enlighten Papa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);