#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([+-]?(?:(?:\d+x\^\d+)|(?:\d+x)|(?:\d+)|(?:x)))"
Local $sString = "2x^3+4x^2+5x-42" & @CRLF & _
"" & @CRLF & _
"2x+x+1"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)