package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([+-]?(?:(?:\d+x\^\d+)|(?:\d+x)|(?:\d+)|(?:x)))`)
var str = `2x^3+4x^2+5x-42
2x+x+1`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}