// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<a.*?href="(.*?)".*?>(.*?)?<\/a>"#).unwrap();
let string = "on <a href=\"https://www.reddit.com/\" target=\"_blank\" rel=\"noopener\">reddit</a> or <a href=\"https://lifehacker.com/\" target=\"_blank\" rel=\"noopener\">Lifehacker</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}