#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*00.*00)(?!.*11.*11)(?=.*00)(?=.*11)[01]+$"
Local $sString = "0101010011" & @CRLF & _
"0011" & @CRLF & _
"010101" & @CRLF & _
"10" & @CRLF & _
"1001011010101010" & @CRLF & _
"10" & @CRLF & _
"10101" & @CRLF & _
"101011" & @CRLF & _
"11010100" & @CRLF & _
"1001100000010101010101" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"010000" & @CRLF & _
"01000100" & @CRLF & _
"" & @CRLF & _
"110011" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")