package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?)?( Com:.*)?$`)
var str = ` Com: 123
abc Com: 123
abc
abc Com:123
abcCom:123
Com:123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}