re = /^(.*?)?( Com:.*)?$/m
str = ' Com: 123
abc Com: 123
abc
abc Com:123
abcCom:123
Com:123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end