use strict;
my $str = 'Markdowndown code blocks work with triple `\'s
This pattern matches prefix, syntax, contents, and postfix
Like this `\\`\\`\\`` or "```" or ``` inline blocks are like this `code here`
x```js
asdf
```
```
test
```
Indented
```
test
```
```js
xyz
```
Indented with syntax
```js
xyz
```
With code content
```js
const foo = () => {}
```
Postfix
```js
const foo = () => {}
```x
With internal ticks
```js
// comment `
const foo = `lol
cool with ticks \\`\\`\\`
`
```';
my $regex = qr/^([A-Za-z \t]*)```([A-Za-z]*)?\n([\s\S]*?)```([A-Za-z \t]*)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}