re = /(?<=(<\/))(.+)(>)/i
str = '<script type="text/javascript">
inner_text_1
<c:set var="" value="">inner_text_2</c:set>
</script>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end