use strict;
my $str = 'CREATE TABLE \'dhcpr_dhcprelayinterface\' (
\'vrId\' integer default 0,
\'ifName\' string ,
PRIMARY KEY(ifName,vrId),
FOREIGN KEY (vrId) REFERENCES \'vr_vr\'(vrId) ON DELETE CASCADE ON UPDATE CASCADE);';
my $regex = qr/CREATE TABLE\s+\'([^\']+)[\s\S]+PRIMARY KEY\(([^,]+),([^\)]+)\)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}