import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #".*?\P{L}*?(\p{L}+-?(\p{L}+)?)\P{L}*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
Veel maatschappen worden opgericht door mensen met een vrij beroep , zoals arts en ,
" Het is leuk 'n
Een goede fiscalist /
Dan kan hij 'n heel leger de baas , 'n
Ik zou denken van wel , eens deze kerel verdwenen zullen er nog erger aan de macht komen , mensen , crimineel krankzinnig , en fanatiek godsdienstig genoeg om met atoombommen naar het westen te smijten...Die
Wie o wie weet er een betaalbare #
De CEO(Chief Executive Officer , algemeen directeur ) en de CFO(Chief Financial Officer , financieel directeur ) moeten een plechtige verklaring afleggen dat alle controles waterdicht zijn en de auditor (
U dient daarbij als verantwoordelijke voor de mutatie-officier '
Vengaboys ( spreek uit : Bengaboys ) is een Nederlandse dance -
Hendriks = J.N. Schouten,
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)