$re = '/\b(?:cpp|h)\b/m';
$str = 'cpp h cph';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);