using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?(\d+)$";
string substitution = @"/user/?user=$1";
string input = @"/demoapi/api/user/123";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}