use strict;
my $str = '/demoapi/api/user/123';
my $regex = qr/^.*?(\d+)$/p;
my $subst = '/user/?user=$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";