re = /^[a-z0-9]+[\._]?[a-z0-9]+[@]\w+[.]\w{2,3}$/m
str = '###################### Valid Emails ########################################################
######################## German, Austrian, international ###################################
janedoe@web.de
jane.doe@web.de
jdoe@web.de
jane-doe@web.de
jane@web.de
doe@web.de
janed@web.de
doej@web.de
jane_doe@web.de
j.doe@web.de
jane.d@web.de
janedoe@t-online.de
jane.doe@t-online.de
jdoe@t-online.de
jane-doe@t-online.de
jane@t-online.de
janed@t-online.de
doej@t-online.de
jane_doe@t-online.de
j.doe@t-online.de
jane.d@t-online.de
janedoe@hotmail.de
jane.doe@hotmail.de
jdoe@hotmail.de
jane-doe@hotmail.de
janedoe@gmx.de
jane.doe@gmx.de
jdoe@gmx.de
jane-doe@gmx.de
jane.doe@post.at
jane-doe@post.at
janedoe@post.at
jane@post.at
john.doe@austrian.com
horneaudrey@fulbright.at
#####################################################################################
########################## Not valid email ##########################################
.test@gmail.com
-test@gmail.com
t.-.est@gmail.com
.test.@gmail.com
test.@gmail.com
test.@.gmail.com
test@.gmail.com
test@.gmail.com.
test@gmail.com.
"email"@example.com
#@%^%#$@#$@#.com
@example.com
Joe Smith <email@example.com>
email.example.com
email@example@example.com
.email@example.com
email.@example.com
email..email@example.com
あいうえお@example.com
email@example.com (Joe Smith)
email@example
email@-example.com
email@example.web
email@111.222.333.44444
email@example..com
Abc..123@example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end