// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-z0-9]+[\._]?[a-z0-9]+[@]\w+[.]\w{2,3}$").unwrap();
let string = "###################### Valid Emails ########################################################
######################## German, Austrian, international ###################################
janedoe@web.de
jane.doe@web.de
jdoe@web.de
jane-doe@web.de
jane@web.de
doe@web.de
janed@web.de
doej@web.de
jane_doe@web.de
j.doe@web.de
jane.d@web.de
janedoe@t-online.de
jane.doe@t-online.de
jdoe@t-online.de
jane-doe@t-online.de
jane@t-online.de
janed@t-online.de
doej@t-online.de
jane_doe@t-online.de
j.doe@t-online.de
jane.d@t-online.de
janedoe@hotmail.de
jane.doe@hotmail.de
jdoe@hotmail.de
jane-doe@hotmail.de
janedoe@gmx.de
jane.doe@gmx.de
jdoe@gmx.de
jane-doe@gmx.de
jane.doe@post.at
jane-doe@post.at
janedoe@post.at
jane@post.at
john.doe@austrian.com
horneaudrey@fulbright.at
#####################################################################################
########################## Not valid email ##########################################
.test@gmail.com
-test@gmail.com
t.-.est@gmail.com
.test.@gmail.com
test.@gmail.com
test.@.gmail.com
test@.gmail.com
test@.gmail.com.
test@gmail.com.
\"email\"@example.com
#@%^%#$@#$@#.com
@example.com
Joe Smith <email@example.com>
email.example.com
email@example@example.com
.email@example.com
email.@example.com
email..email@example.com
あいうえお@example.com
email@example.com (Joe Smith)
email@example
email@-example.com
email@example.web
email@111.222.333.44444
email@example..com
Abc..123@example.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}