$re = '/INSERT INTO(.|\n|\r)*\)/U';
$str = 'INSERT INTO (фывфыв ( фывфыв) ) фывфывф)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);