package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(` (\s*<\/p>\s*<p>){2,}`)
var str = `<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p></p><p> paragraph3</p>
<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p>
</p><p> paragraph3</p>
<p>paragraph1 <br /> Newline </p><p> paragraph2 </p><p> </p><p> paragraph3</p>`
var substitution = " <\/p><p>"
fmt.Println(re.ReplaceAllString(str, substitution))
}