#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(/dev/[\S]+|zroot\S*?) on (/.*) \(([a-zA-Z0-9]+), .+, (.+)\)$"
Local $sString = "ZFS filesystem" & @CRLF & _
"" & @CRLF & _
"zroot on / (zfs, local, nfsv4acls)" & @CRLF & _
"zroot/tmp on /tmp (zfs, local, nosuid, nfsv4acls)" & @CRLF & _
"zroot/usr on /usr (zfs, local, nfsv4acls)" & @CRLF & _
"zroot/usr/home on /usr/home (zfs, local, nfsv4acls)" & @CRLF & _
"zroot/usr/home/vagrant on /usr/home/vagrant (zfs, local, nfsv4acls)" & @CRLF & _
"zroot/usr/ports on /usr/ports (zfs, local, nosuid, nfsv4acls)" & @CRLF & _
"zroot/usr/ports/distfiles on /usr/ports/distfiles (zfs, local, noexec, nosuid, nfsv4acls)" & @CRLF & _
"zroot/usr/ports/packages on /usr/ports/packages (zfs, local, noexec, nosuid, nfsv4acls)" & @CRLF & _
"zroot/usr/src on /usr/src (zfs, local, noexec, nosuid, nfsv4acls)" & @CRLF & _
"zroot/var on /var (zfs, local, nfsv4acls)" & @CRLF & _
"zroot/var/crash on /var/crash (zfs, local, noexec, nosuid, nfsv4acls)" & @CRLF & _
"zroot/var/db on /var/db (zfs, local, noexec, nosuid, nfsv4acls)" & @CRLF & _
"zroot/var/db/pkg on /var/db/pkg (zfs, local, nosuid, nfsv4acls)" & @CRLF & _
"zroot/var/empty on /var/empty (zfs, local, noexec, nosuid, read-only, nfsv4acls)" & @CRLF & _
"zroot/var/log on /var/log (zfs, local, noexec, nosuid, nfsv4acls)" & @CRLF & _
"zroot/var/mail on /var/mail (zfs, local, noexec, nosuid, nfsv4acls)" & @CRLF & _
"zroot/var/run on /var/run (zfs, local, noexec, nosuid, nfsv4acls)" & @CRLF & _
"zroot/var/tmp on /var/tmp (zfs, local, nosuid, nfsv4acls)" & @CRLF & _
"" & @CRLF & _
"Non ZFS filesystem" & @CRLF & _
"" & @CRLF & _
"/dev/mfid0p2 on / (ufs, local, journaled soft-updates)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")