using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*http:.*";
string input = @"//this line should be ignored http://foo.com
NSString *url = @""http://foo.com""; //this line should show up as a result";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}