$re = '/(?![EB]#)([A-G])([#b])?/m';
$str = 'A
A#
Ab
B
B#
Bb
C
C#
Cb
D
D#
Db
E
E#
Eb
F
F#
Fb
G
G#
Gb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);