// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*StringToSearch:\n[^\n]+").unwrap();
let string = "Lorem ipsum dolor sit amet
StringToSearch:
| isoCode |
consectetur adipiscing elit
StringToSearch:
| isoCode |
sed do eiusmod tempor incididunt
ut labore et dolore magna aliqua
StringToSearch:
| isoCode |
";
let substitution = "$&\\n\\t\\t\\t| uk |";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}