# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/,(?=(?:[^"]*""?[^"]*")*[^"]*$)/\n/gim;t' <<< "\"This is a string\", \"and this is another with a , in it\", Thisisalsovalid, \"\",,,\"And a string\""